Indice del forum Olimpo Informatico
I Forum di Zeus News
Leggi la newsletter gratuita - Attiva il Menu compatto
 
 FAQFAQ   CercaCerca   Lista utentiLista utenti   GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo   Messaggi privatiMessaggi privati   Log inLog in 

    Newsletter RSS Facebook Twitter Contatti Ricerca
Lubuntu 19.10 - VLC non riproduce alcuni audio
Nuovo argomento   Rispondi    Indice del forum -> *Ubuntu
Precedente :: Successivo  
Autore Messaggio
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 08 Mag 2020 22:51    Oggetto: Lubuntu 19.10 - VLC non riproduce alcuni audio Rispondi citando

Sistema nuovo, problemi nuovi. Rolling Eyes

Ho da poco installato Lubuntu 19.10 e, venendo dalla stessa versione di Xubuntu, non mi aspettavo grandi cambiamenti, a parte il desktop. Invece qualche problema c'è.

Uno dei più fastidiosi è che VLC non riproduce l'audio di alcuni video.

Ho provato altri lettori. Gli stessi file non vengono riprodotti nemmeno da Clementine, che non li apre proprio e dice
Codice:
Your GStreamer installation is missing a plug-in


Invece altri lettori come MPV Media Player (preinstallato nel sistema) e SM Player li riproducono normalmente. Quindi il problema non è nei file.

Dato il messaggio di Clementine, sono andata a controllare quali pacchetti GStreamer sono installati

Codice:
gstreamer1.0-plugins-good
gstreamer1.0-plugins-base
libgstreamer-plugins-good1.0-0
gstreamer1.0-pulseaudio
gstreamer1.0-gtk3
libgstreamer-gl1.0-0
libgstreamer-plugins-base1.0-0
gstreamer1.0-x
libgstreamer1.0-0
gstreamer1.0-gl
gstreamer1.0-plugins-ugly


Ce ne sono molti altri disponibili, ma non saprei proprio cosa provare ad installare.

Ho guardato anche i pacchetti VLC e fra i pochi non installati non vedo niente che sembri riguardare codec audio.

I file che danno problemi sono come questo

Codice:
General
Complete name                            : /home/nome.mp4
Format                                   : MPEG-4
Format profile                           : Base Media
Codec ID                                 : isom (isom/iso2/avc1/mp41)
File size                                : 54.3 MiB
Duration                                 : 5 min 5 s
Overall bit rate                         : 1 493 kb/s
Movie name                               : 575143822675305
Writing application                      : Lavf56.4.101

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L3.1
Format settings                          : CABAC / 5 Ref Frames
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 5 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 5 min 4 s
Bit rate                                 : 1 442 kb/s
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.063
Stream size                              : 52.4 MiB (96%)
Writing library                          : x264 core 142
Encoding settings                        : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=0 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=0 / threads=48 / lookahead_threads=5 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=90 / keyint_min=9 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=27.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / vbv_maxrate=2500 / vbv_bufsize=5000 / crf_max=0.0 / nal_hrd=none / filler=0 / ip_ratio=1.40 / aq=2:1.00
Codec configuration box                  : avcC

Audio
ID                                       : 2
Format                                   : AAC LC SBR PS
Format/Info                              : Advanced Audio Codec Low Complexity with Spectral Band Replication and Parametric Stereo
Commercial name                          : HE-AACv2
Format settings                          : Explicit
Codec ID                                 : mp4a-40-2
Duration                                 : 5 min 5 s
Duration_LastFrame                       : 125 ms
Bit rate mode                            : Constant
Bit rate                                 : 48.0 kb/s
Channel(s)                               : 2 channels
Channel layout                           : C
Sampling rate                            : 48.0 kHz
Frame rate                               : 23.438 FPS (2048 SPF)
Compression mode                         : Lossy
Stream size                              : 1.74 MiB (3%)
Language                                 : Italian
Default                                  : Yes
Alternate group                          : 1
Top
Profilo Invia messaggio privato
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 9527

MessaggioInviato: 08 Mag 2020 23:33    Oggetto: Rispondi citando

Il pacchetto ubuntu-restricted-extras ce l'hai installato?

Prova ad aprire VLC e Clementine da terminale, e vedi che errori ti danno quando apri quei video.
Top
Profilo Invia messaggio privato
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 09 Mag 2020 00:48    Oggetto: Rispondi citando

Avevo dovuto installare quel pacchetto in passato perché non riuscivo a vedere alcuni DVD, ma ovviamente me ero dimenticata e quindi non l'ho provato.

Adesso l'ho installato. Ora la situazione è che con Clementine sento l'audio (solo l'audio ovviamente: mi ero scordata che non è un player per i video Laughing ).

VLC continua invece a non riprodurre l'audio. Aprendo il video da interfaccia grafica ho anche controllato che la traccia audio fosse selezionata. Mi sono anche accorta che non è completamente muta: di tanto in tanto si sentono dei brevi suoni.

Aprendo il video da terminale

Codice:
VLC media player 3.0.8 Vetinari (revision 3.0.8-0-gf350b6b5a7)                                                                                               
[0000561ead4675b0] main libvlc: Esecuzione di vlc con l'interfaccia predefinita. Usa 'cvlc' per utilizzare vlc senza interfaccia.                           
libva info: VA-API version 1.5.0                                                                                                                             
libva info: va_getDriverName() returns 0                                                                                                                     
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so                                                                               
libva info: Found init function __vaDriverInit_1_5                                                                                                           
libva info: va_openDriver() returns 0                                                                                                                       
[00007f1d40c107f0] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed                                                                               
[00007f1d1404b020] main video output error: video output creation failed                                                                                     
[00007f1d20f13630] main decoder error: failed to create video output                                                                                         
[00007f1d20f13630] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding                                               
[h264 @ 0x7f1d20f45200] Failed setup for format vdpau: hwaccel initialisation returned error.                                                               
[00007f1d20f13630] avcodec decoder error: existing hardware acceleration cannot be reused                                                                   
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: Found init function __vaDriverInit_1_5
libva info: va_openDriver() returns 0
[00007f1d40118790] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
libva info: VA-API version 1.5.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: Found init function __vaDriverInit_1_5
libva info: va_openDriver() returns 0
[00007f1d40c03c80] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007f1d14077600] main video output error: video output creation failed
[00007f1d20f13630] main decoder error: failed to create video output


E' strano perché riferisce errori video, ma il video si vede benissimo. E' l'audio che non va. Confused
Top
Profilo Invia messaggio privato
MK66
Moderatore Sistemi Operativi
Moderatore Sistemi Operativi


Registrato: 17/10/06 22:24
Messaggi: 8453
Residenza: dentro una cassa sotto 3 metri di terra...

MessaggioInviato: 09 Mag 2020 11:38    Oggetto: Rispondi citando

@Maary79, scusa l'intromissione, ma questo l'ho già visto in passato
Citazione:
glconv_vaapi_x11 gl error: vaDeriveImage: operation failed


Apri VLC e vai su Strumenti => Preferenze => Video => Uscita, di solito è selezionato Default o Automatico nel menù a tendina, cambia con X11 e dovrebbe andare
Top
Profilo Invia messaggio privato HomePage
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 09 Mag 2020 14:58    Oggetto: Rispondi citando

Purtroppo non ha funzionato. Sad
Top
Profilo Invia messaggio privato
SverX
Supervisor Macchinisti
Supervisor Macchinisti


Registrato: 25/03/02 11:16
Messaggi: 10583
Residenza: Tokelau

MessaggioInviato: 09 Mag 2020 15:17    Oggetto: Rispondi citando

VLC che usi è l'ultima versione o quella nel repository?

nel caso sia quello nel repository, prova a toglierlo e a mettere l'ultima versione, vediamo che capita
Top
Profilo Invia messaggio privato HomePage
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 09 Mag 2020 16:18    Oggetto: Rispondi citando

Avevo quella del repository. Ora ho installato la 3.0.10 che è l'ultima stabile.

Anche questo non risolve. Confused

Ma visto che con gli altri player quei video funzionano, deve proprio essere un problema di VLC. Sarebbe bello capire quale elemento non gli piace.

E' il mio player preferito da molti anni, ma ultimamente mi sta dando alcune delusioni. Ad esempio non riproduce i .webm con il video codificato in VP9 (che in tutti gli altri player funzionano). Confused
Top
Profilo Invia messaggio privato
SverX
Supervisor Macchinisti
Supervisor Macchinisti


Registrato: 25/03/02 11:16
Messaggi: 10583
Residenza: Tokelau

MessaggioInviato: 09 Mag 2020 20:40    Oggetto: Rispondi citando

l'unica cosa che ho trovato relativa al problema con quel codec audio è questo suggerimento:

Citazione:
vai in Tools > Preferences > Input/Codecs > Video codecs > FFmpeg cambia 'Strict standard compliance" al valore -2


vedi se sistema, onestamente non so - sul forum di VLC c'è uno che ha il tuo stesso problema ma non gli hanno saputo ancora rispondere Confused
Top
Profilo Invia messaggio privato HomePage
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 09 Mag 2020 22:38    Oggetto: Rispondi citando

Ce l'ho in italiano e ci ho messo 5 minuti a trovarlo. Dovrebbe essere "Rispetto rigoroso della norma".

Comunque niente da fare. Sad A questo punto credo che dovrò accontentarmi e usare i player alternativi quando necessario.
Top
Profilo Invia messaggio privato
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 9527

MessaggioInviato: 09 Mag 2020 23:28    Oggetto: Rispondi citando

In realtà, ho avuto problemi pure io con VLC. Player che ho amato molto con Windows, anche se poi in Linux ho sempre usato quello che trovavo installato, che non sempre era VLC.
Non ricordo di aver mai avuto problemi audio, con VLC, ma solo video (alcuni andavano a scatti, o si bloccavano), cosa che Totem, MPlayer, o altri non succedeva.
VLC però ha delle opzioni particolari. Ad esempio ti dice con che codec (audio-video) è stato fatto il video. Che codifica ha?
Si sente con altri player?
Se no, di potrebbe ricodificare.

PS: ciao MK66 ben ritrovato! Il comando da terminale, glielo ho fatto dare per abitudine.... Wink non sempre riesco a codificare l'output, ogni occhio in più, è più che gradito!

Pps: rettifico un errore; non è ubuntu-restricted-extras ma lubuntu-restricted-extras
Top
Profilo Invia messaggio privato
SverX
Supervisor Macchinisti
Supervisor Macchinisti


Registrato: 25/03/02 11:16
Messaggi: 10583
Residenza: Tokelau

MessaggioInviato: 10 Mag 2020 11:54    Oggetto: Rispondi citando

elisa.r ha scritto:
Ce l'ho in italiano e ci ho messo 5 minuti a trovarlo. Dovrebbe essere "Rispetto rigoroso della norma".

Comunque niente da fare. Sad A questo punto credo che dovrò accontentarmi e usare i player alternativi quando necessario.


scusa, mi sono accorto adesso che ho suggerito una cosa relativa al video e non all'audio.

a questo punto rilancio con questa:

Citazione:
Tools -> Preferences -> Audio/Codex -> "Preferred decoders list" e rimuovi "quicktime" se presente


e dopo non saprei più davvero Sad
Top
Profilo Invia messaggio privato HomePage
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 10 Mag 2020 18:07    Oggetto: Rispondi citando

Non riesco a trovare quell'opzione.


Maary79 ha scritto:
In realtà, ho avuto problemi pure io con VLC. Player che ho amato molto con Windows, anche se poi in Linux ho sempre usato quello che trovavo installato, che non sempre era VLC.
Non ricordo di aver mai avuto problemi audio, con VLC, ma solo video (alcuni andavano a scatti, o si bloccavano), cosa che Totem, MPlayer, o altri non succedeva.
VLC però ha delle opzioni particolari. Ad esempio ti dice con che codec (audio-video) è stato fatto il video. Che codifica ha?
Si sente con altri player?
Se no, di potrebbe ricodificare.

PS: ciao MK66 ben ritrovato! Il comando da terminale, glielo ho fatto dare per abitudine.... Wink non sempre riesco a codificare l'output, ogni occhio in più, è più che gradito!

Pps: rettifico un errore; non è ubuntu-restricted-extras ma lubuntu-restricted-extras


Ho messo lubuntu-restricted-extras ma non è servito.

Le specifiche del file le ho ricavate con Media Info e le ho messe nel primo post. Servono altre informazioni?
Con tutti gli altri player il video funziona.
A ricodificare non ci penso. Sono brevi, ma sono una trentina e ci vuole troppo. Di solito diventano anche molto più grandi e io ho problemi di spazio.
Top
Profilo Invia messaggio privato
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 9527

MessaggioInviato: 11 Mag 2020 12:43    Oggetto: Rispondi citando

Prova andare su strumenti - informazioni codificatore - dovrebbe proprio darti il tipo di codifica audio che ha.
Comunque un ricodificatore leggero, ed efficace è ffmpeg, funziona da terminale.
Anche solo per fare esperimenti dacci un'occhiata. Wink
link
Top
Profilo Invia messaggio privato
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 11 Mag 2020 15:12    Oggetto: Rispondi citando

Codificatore Confused




Farò qualche esperimento con ffmpeg.
Top
Profilo Invia messaggio privato
SverX
Supervisor Macchinisti
Supervisor Macchinisti


Registrato: 25/03/02 11:16
Messaggi: 10583
Residenza: Tokelau

MessaggioInviato: 11 Mag 2020 16:16    Oggetto: Rispondi citando

comunque mi sembra assurdo che VLC non decodifichi audio AAC.

prova a vedere il dettaglio su qualche video che riesci a sentire, magari scopriamo che il problema invece è che non gli piacciono i 48KHz, che è più probabile

edit: sotto Tools > Messages, metti Verbosity a livello 2 e dopo prova a fare play, vediamo cosa viene fuori...
Top
Profilo Invia messaggio privato HomePage
Maary79
Moderatrice Sistemi Operativi e Software
Moderatrice Sistemi Operativi e Software


Registrato: 08/02/12 12:23
Messaggi: 9527

MessaggioInviato: 11 Mag 2020 17:06    Oggetto: Rispondi citando

AAC lo decodifica. Io ne ho molti con quella codifica audio, con VLC si sente.
Non mi è chiara quell'estensione SBR, non l'ho mai vista.
Con cosa sono stati fatti quei video?
Top
Profilo Invia messaggio privato
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 12 Mag 2020 16:20    Oggetto: Rispondi citando

Non so con cosa sono stati fatti video perché li ho scaricati.

***
EDIT AGGIORNAMENTO Non avevo capito cosa dovevo fare con VLC, ma poi l'ho fatto. Il log è kilometrico, quindi non lo posto qui (non ricordo dove va postato) però ripete sempre
Codice:
faad warning: First SBR frame is not the same as first AAC frame


Questo messaggio non appare nei video in cui l'audio si sente.


***

Prima ho confrontato con Media Info uno dei file che non si sente e uno simile che invece si sente. La differenza più importante che salta all'occhio è che il tipo di AAC è diverso:
(sono entrambi a 48 kHz, quindi il problema non dovrebbe essere quello).

NON si sente:

Codice:
Format                                   : AAC LC SBR PS
Format/Info                              : Advanced Audio Codec Low Complexity with Spectral Band Replication and Parametric Stereo
Commercial name                          : HE-AACv2
Format settings                          : Explicit
Codec ID                                 : mp4a-40-2



Si sente:

Codice:
Format                                   : AAC LC SBR
Format/Info                              : Advanced Audio Codec Low Complexity with Spectral Band Replication
Commercial name                          : HE-AAC
Format settings                          : NBC
Codec ID                                 : mp4a-40-5


Purtroppo non posso sapere se nel pc ho dei video con il profilo uguale al primo, ma che si sentono, perché dovrei controllarli tutti. Shocked
Codice:
Top
Profilo Invia messaggio privato
SverX
Supervisor Macchinisti
Supervisor Macchinisti


Registrato: 25/03/02 11:16
Messaggi: 10583
Residenza: Tokelau

MessaggioInviato: 12 Mag 2020 18:08    Oggetto: Rispondi citando

OK direi che è un problema della libreria faad, ma non penso avrai voglia di ricompilartela

se questo comando:

Codice:
sudo apt-get install faad


dice che ce l'hai già installata, direi che siamo al capolinea Confused
Top
Profilo Invia messaggio privato HomePage
elisa.r
Semidio
Semidio


Registrato: 18/11/12 16:05
Messaggi: 396

MessaggioInviato: 12 Mag 2020 18:43    Oggetto: Rispondi citando

Invece non c'era. Però dopo l'installazione non è cambiato nulla.
A questo punto direi che può bastare, anche perché c'è pieno di lettori là fuori che riproducono i suddetti video senza problemi. Meno male che VLC è il migliore. Sì, avrà un sacco di funzioni in più, ma anche tanti problemi in più. Rolling Eyes
Top
Profilo Invia messaggio privato
SverX
Supervisor Macchinisti
Supervisor Macchinisti


Registrato: 25/03/02 11:16
Messaggi: 10583
Residenza: Tokelau

MessaggioInviato: 13 Mag 2020 18:26    Oggetto: Rispondi

VLC 2.2.x o VLC 3.0.x ?
Top
Profilo Invia messaggio privato HomePage
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> *Ubuntu Tutti i fusi orari sono GMT + 1 ora
Vai a 1, 2  Successivo
Pagina 1 di 2

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi